解决安装maven for eclipse插件后,eclipse启动时警告错误

When using the Maven plugin for Eclipse if you get the following message :

 

The Maven Integration requires that Eclipse be running in a JDK, because a   number of Maven core plugins are using jars from the JDK.  Please make sure the -vm option in eclipse.ini is pointing to a JDK and verify  that Installed JREs are also using JDK installs.

To solve this problem add a new option into your eclipse.ini (which is located in your Eclipse installation folder):

-vm C:\Program Files\Java\jdk1.6.0_06\bin\javaw.exe

It is important to have this line on the correct location, otherwise Eclipse will have no clue about this setting:

-showsplashorg.eclipse.platform
--launcher.XXMaxPermSize256M
-vm
C:\Program Files\Java\jdk1.6.0_06\bin\javaw.exe
-vmargs-Dosgi.requiredJavaVersion=1.5-Xms40m-Xmx512m
It has to be before the -vmargs argument.